记录黑客技术中优秀的内容,传播黑客文化,分享黑客技术精华

CVE-2022-2884:GitLab远程代码执行漏洞通告

2022-08-25 14:14

 

0x01   漏洞简述

2022年08月23日,360CERT监测发现GitLab发布了GitLab CE/EE的风险通告,漏洞编号为CVE-2022-2884,漏洞等级:严重,漏洞评分:9.9。

GitLab 是一个用于仓库管理系统的开源项目,使用 Git 作为代码管理工具,可通过 Web 界面访问公开或私人项目。

对此,360CERT建议广大用户及时将GitLab CE/EE升级到最新版本。与此同时,请做好资产自查以及预防工作,以免遭受黑客攻击。

 

0x02   风险等级

360CERT对该漏洞的评定结果如下

评定方式等级
威胁等级严重
影响面广泛
攻击者价值
利用难度
360CERT评分9.9

 

0x03   漏洞详情

CVE-2022-2884: GitLab CE/EE代码执行漏洞

CVE: CVE-2022-2884

组件: GitLab CE/EE

漏洞类型: 代码执行

影响: 服务器接管

简述: 该漏洞存在于GitLab社区版(CE)和企业版(EE)中,允许经过身份验证的攻击者通过GitHub API端点导入的方式远程执行代码,最终接管服务器。

 

0x04   影响版本

组件影响版本安全版本
GitLab CE/EE11.3.4 – 15.1.515.1.5
GitLab CE/EE15.2 – 15.2.315.2.3
GitLab CE/EE15.3 – 15.3.115.3.1

 

0x05   修复建议

通用修补建议

根据影响版本中的信息,排查并升级到安全版本。

下载链接:https://about.gitlab.com/update/

 

0x06   产品侧解决方案

若想了解更多产品信息或有相关业务需求,可移步至http://360.net。

360安全分析响应平台

360安全大脑的安全分析响应平台通过网络流量检测、多传感器数据融合关联分析手段,对该类漏洞的利用进行实时检测和阻断,请用户联系相关产品区域负责人获取对应产品。

360安全卫士

Windows用户可通过360安全卫士实现对应补丁安装、漏洞修复、恶意软件查杀,其他平台的用户可以根据修复建议列表中的安全建议进行安全维护。

360CERT建议广大用户使用360安全卫士定期对设备进行安全检测,以做好资产自查以及防护工作。

360安全卫士团队版

用户可以通过安装360安全卫士并进行全盘杀毒来维护计算机安全。360CERT建议广大用户使用360安全卫士定期对设备进行安全检测,以做好资产自查以及防护工作。

360本地安全大脑

360本地安全大脑是将360云端安全大脑核心能力本地化部署的一套开放式全场景安全运营平台,实现安全态势、监控、分析、溯源、研判、响应、管理的智能化安全运营赋能。360本地安全大脑已支持对相关漏洞利用的检测,请及时更新网络神经元(探针)规则和本地安全大脑关联分析规则,做好防护。

 

0x07   时间线

2022-08-22 Gitlab官方发布通告

2022-08-23 360CERT发布通告

 

0x08   参考链接

1、 https://about.gitlab.com/releases/2022/08/22/critical-security-release-gitlab-15-3-1-released/


知识来源: https://www.anquanke.com/post/id/278684

阅读:203025 | 评论:0 | 标签:漏洞 CVE 远程 执行 远程代码执行

想收藏或者和大家分享这篇好文章→复制链接地址

“CVE-2022-2884:GitLab远程代码执行漏洞通告”共有0条留言

发表评论

姓名:

邮箱:

网址:

验证码:

黑帝公告 📢

十年经营持续更新精选优质黑客技术文章Hackdig,帮你成为掌握黑客技术的英雄

🙇🧎营运续持们我助帮↓

标签云 ☁