记录黑客技术中优秀的内容,传播黑客文化,分享黑客技术精华

libIEC61850整数下溢漏洞

2020-09-02 14:02
CNVD-IDCNVD-2020-49952
公开日期2020-09-02
危害级别 高(AV:N/AC:L/Au:N/C:P/I:P/A:P)
影响产品libIEC61850 libIEC61850 <1.4.3
CVE IDCVE-2020-15158
漏洞描述libIEC61850是IEC 61850客户端和服务器库的开源(GPLv3)实现。

libIEC61850 1.4.3之前版本存在整数下溢漏洞,攻击者可通过COTP消息长度字段值小于4的消息利用该漏洞导致堆缓冲区溢出,应用程序崩溃或实现远程代码执行。
漏洞类型 通用型漏洞
参考链接https://nvd.nist.gov/vuln/detail/CVE-2020-15158
漏洞解决方案厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/mz-automation/libiec61850/commit/033ab5b6488250c8c3b838f25a7cbc3e099230bb
厂商补丁libIEC61850整数下溢漏洞的补丁
验证信息(暂无验证信息)
报送时间2020-08-27
收录时间2020-09-02
更新时间2020-09-02
漏洞附件(无附件)
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。

知识来源: https://www.cnvd.org.cn/flaw/show/CNVD-2020-49952

阅读:15142 | 评论:0 | 标签:漏洞

想收藏或者和大家分享这篇好文章→复制链接地址

“libIEC61850整数下溢漏洞”共有0条留言

发表评论

姓名:

邮箱:

网址:

验证码:

公告

❤人人都能成为掌握黑客技术的英雄❤

ADS

标签云