记录黑客技术中优秀的内容,传播黑客文化,分享黑客技术精华

CVE-2021-3064: 全球保护 VPN 中帕洛阿尔托网络中易于开发的 RCE 漏洞

2021-11-12 12:15

帕洛阿尔托网络在其全球保护门户和网关界面中披露了一个关键的远程代码执行漏洞,跟踪为CVE-2021-3064。网络安全供应商警告说,该漏洞很容易被基于网络的非法攻击者利用。成功的开发可能导致系统过程的中断,并可能导致具有根特权的任意代码执行。

"Palo Alto 网络全球保护门户和网关界面存在内存腐败漏洞,使基于网络的未授权攻击者能够中断系统进程,并可能使用根特权执行任意代码。攻击者必须访问全球保护界面才能利用此问题。

该漏洞比 PAN-OS 8.1.17 更早影响 PAN-OS 8.1 版本,它获得了 9.8 的 CVSS v3.1 基本分数。这个漏洞是由兰多里公司的研究人员发现的。

帕洛阿尔托网络不知道任何攻击在野外利用这个漏洞。

"CVE-2021-3064 是一种缓冲溢出,当将用户提供的输入解析到堆栈上的固定长度位置时,就会发生缓冲溢出。如果不使用 HTTP 走私技术,则无法在外部联系到有问题的代码。在防火墙设备上受影响的组件的特权下,这些功能的利用共同产生远程代码执行。 走私能力未被指定为 CVE 标识符,因为受影响的供应商不认为该识别符是安全边界。

根据 Randori 攻击团队,攻击者必须具有对 Global 保护服务端口(默认端口 443)上的设备的网络访问权限。专家指出,这个端口经常可以通过互联网访问。启用 ASLR 时,利用更加困难,而在虚拟化设备(VM 系列防火墙)上,由于缺少 ASLR,攻击要容易得多。

"我们的团队能够获取受影响目标的外壳、访问敏感的配置数据、提取凭据等。一旦攻击者控制了防火墙,他们就能看到内部网络,并可以横向移动。兰多里说。

以下是此漏洞的时间表:

  • 2020-10-26:兰多里开始对全球保护进行初步研究。
  • 2020-11-19:兰多里发现了缓冲溢出漏洞。
  • 2020-11-20:兰多里发现了HTTP的走私能力。
  • 2020-12-01:兰多里开始授权使用漏洞链作为兰多里连续和自动化的红色团队平台的一部分。
  • 2021-09-22:兰多里向PAN披露了缓冲溢出漏洞。
  • 2021-10-11:兰多里向PAN披露了HTTP的走私能力。
  • 2021-11-10:PAN 发布了补丁和安全公告,指定漏洞 CVE-2021-3064。
  • 2021-11-10:本报告已发表。



知识来源: https://www.wangan.com/p/7fygf36e15b24838

阅读:36241 | 评论:0 | 标签:漏洞 CVE 保护 网络 RCE VPN

想收藏或者和大家分享这篇好文章→复制链接地址

“CVE-2021-3064: 全球保护 VPN 中帕洛阿尔托网络中易于开发的 RCE 漏洞”共有0条留言

发表评论

姓名:

邮箱:

网址:

验证码:

公告

永久免费持续更新精选优质黑客技术文章Hackdig,帮你成为掌握黑客技术的英雄

求打赏·赞助·支持💖

标签云