记录黑客技术中优秀的内容,传播黑客文化,分享黑客技术精华

CVE-2008-2830-漏洞详情

2021-11-15 20:47
CVE-2008-2830
CVSS 7.2
发布时间 :2008-06-23 16:41:00
修订时间 :2011-03-07 22:09:49
NMCOS    

[原文]Open Scripting Architecture in Apple Mac OS X 10.4.11 and 10.5.4, and some other 10.4 and 10.5 versions, does not properly restrict the loading of scripting addition plugins, which allows local users to gain privileges via scripting addition commands to a privileged application, as originally demonstrated by an osascript tell command to ARDAgent.


[CNNVD]Apple Mac OS X ARDAgent 权限许可和服务控制漏洞(CNNVD-200806-319)

        Mac OS X是苹果家族机器所使用的操作系统。


        本地攻击者可以通过AppleScript(如osascript)调用Mac OS X的ARDAgent。ARDAgent属于root用户,且设置了setuid位,也就是攻击者可以利用这个漏洞以root权限执行任意shell命令。目前这个漏洞正在被名为AppleScript.THT的木马积极的利用。一旦用户受骗安装了带有木马的恶意文件,木马就会打开文件共享、Web共享和远程登录。木马的默认文件名为AStht_06.app,安装位置/Library/Caches。


        


CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]


CWE (弱点类目)

CWE-264 [权限、特权与访问控制]


CPE (受影响的平台与产品)

cpe:/o:apple:mac_os_x:10.4 Apple Mac OS X 10.4
cpe:/o:apple:mac_os_x:10.5 Apple Mac OS X 10.5


OVAL (用于检测的技术细节)

未找到相关OVAL定义


官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2830

(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2008-2830

(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200806-319

(官方数据源) CNNVD


其它链接及资源

http://xforce.iss.net/xforce/xfdb/43294


(UNKNOWN)  XF  apple-macosx-ardagent-command-execution(43294)
http://www.vupen.com/english/advisories/2008/1905/references


(UNKNOWN)  VUPEN  ADV-2008-1905
http://www.securitytracker.com/id?1020345


(UNKNOWN)  SECTRACK  1020345
http://www.securityfocus.com/bid/29831


(UNKNOWN)  BID  29831
http://secunia.com/advisories/30776


(UNKNOWN)  SECUNIA  30776
http://lists.apple.com/archives/security-announce//2008/Jul/msg00003.html


(UNKNOWN)  APPLE  APPLE-SA-2008-07-31
http://lists.apple.com/archives/security-announce//2008//Sep/msg00006.html


(UNKNOWN)  APPLE  APPLE-SA-2008-09-16
http://it.slashdot.org/it/08/06/18/1919224.shtml


(UNKNOWN)  MISC  http://it.slashdot.org/it/08/06/18/1919224.shtml


漏洞信息

Apple Mac OS X ARDAgent 权限许可和服务控制漏洞
高危 权限许可和访问控制
2008-06-23 00:00:00 2008-11-19 00:00:00
本地  
        Mac OS X是苹果家族机器所使用的操作系统。


        本地攻击者可以通过AppleScript(如osascript)调用Mac OS X的ARDAgent。ARDAgent属于root用户,且设置了setuid位,也就是攻击者可以利用这个漏洞以root权限执行任意shell命令。目前这个漏洞正在被名为AppleScript.THT的木马积极的利用。一旦用户受骗安装了带有木马的恶意文件,木马就会打开文件共享、Web共享和远程登录。木马的默认文件名为AStht_06.app,安装位置/Library/Caches。


        


公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:


        http://www.apple.com


漏洞信息


46490
Apple Mac OS X ARDAgent osascript tell Command Local Privilege Escalation

Local Access Required

Input Manipulation
Loss of Integrity
Exploit Public Uncoordinated Disclosure


漏洞描述

Mac OS X contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered when the suid ARDAgent is directed to 'do shell script' and it runs the specified script with root permissions. This flaw may lead to a loss of integrity.


时间线


2008-06-18

Unknow
2008-06-18 Unknow


解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.


相关参考


漏洞作者


漏洞信息

Apple Mac OS X AppleScript ARDAgent Shell Local Privilege Escalation Vulnerability

Access Validation Error

29831
No Yes
2008-06-19 12:00:00 2008-09-16 10:40:00

anonymous


受影响的程序版本

Apple Remote Desktop 3.2.1

Apple Mac OS X Server 10.5.4

Apple Mac OS X Server 10.5.3

Apple Mac OS X Server 10.5.2

Apple Mac OS X Server 10.5.1

Apple Mac OS X Server 10.4.11

Apple Mac OS X Server 10.4.10

Apple Mac OS X Server 10.4.9

Apple Mac OS X Server 10.4.8

Apple Mac OS X Server 10.4.7

Apple Mac OS X Server 10.4.6

Apple Mac OS X Server 10.4.5

Apple Mac OS X Server 10.4.4

Apple Mac OS X Server 10.4.3

Apple Mac OS X Server 10.4.2

Apple Mac OS X Server 10.4.1

Apple Mac OS X Server 10.4

Apple Mac OS X Server 10.5

Apple Mac OS X 10.5.4

Apple Mac OS X 10.5.3

Apple Mac OS X 10.5.2

Apple Mac OS X 10.5.1

Apple Mac OS X 10.4.11

Apple Mac OS X 10.4.10

Apple Mac OS X 10.4.9

Apple Mac OS X 10.4.8

Apple Mac OS X 10.4.7

Apple Mac OS X 10.4.6

Apple Mac OS X 10.4.5

Apple Mac OS X 10.4.4

Apple Mac OS X 10.4.3

Apple Mac OS X 10.4.2

Apple Mac OS X 10.4.1

Apple Mac OS X 10.4

Apple Mac OS X 10.5

Apple Remote Desktop 3.2.2


不受影响的程序版本

Apple Remote Desktop 3.2.2


漏洞讨论

Mac OS X is prone to a local privilege-escalation vulnerability affecting ARDAgent (Apple Remote Desktop).



Successful exploits allow local attackers to execute arbitrary code with superuser privileges, completely compromising the affected computer.



This issue is confirmed to affect Mac OS X 10.5 versions; earlier versions may also be vulnerable.


漏洞利用

The following exploit code is available:



osascript -e 'tell app “ARDAgent” to do shell script “whoami”';



NOTE: This issue is being exploited by the 'AppleScript.THT' trojan to gain elevated privileges. Please see the references for more information.


解决方案

The vendor has released fixes and an advisory. Please see the references for more information.





Apple Mac OS X 10.5.4



Apple Mac OS X Server 10.5.4



Apple Remote Desktop 3.2.1


相关参考


知识来源: https://vulsee.com/archives/vulsee_2021/1115_5041.html

阅读:77940 | 评论:0 | 标签:漏洞收集 CVE-2008-2830 漏洞 CVE

想收藏或者和大家分享这篇好文章→复制链接地址

“CVE-2008-2830-漏洞详情”共有0条留言

发表评论

姓名:

邮箱:

网址:

验证码:

黑帝公告 📢

永久免费持续更新精选优质黑客技术文章Hackdig,帮你成为掌握黑客技术的英雄

标签云 ☁